I just tried to upload an image in a question on meta.devops but it failed with:

Failed to upload image; an error occured at imgur | Close

Is there something specific that needs to be set up for a new beta site for this to be working?

Note: it doesn't work on other SE sites either (just tried on SoftwareEngineering, same error.

  • S3's down in US - East, I wager that might be the reason Commented Feb 28, 2017 at 18:15
  • Can you try with different image (different type)? Does the same image uploads on other SE sites?
    – kenorb
    Commented Feb 28, 2017 at 18:16
  • Indeed, it doesn't work on other SE sites either (just tried on SoftwareEngineering, same error). Commented Feb 28, 2017 at 18:17
  • IMO this question is a possible candidate for being closed ... It's aboot a problem (or bug or something) that cannot (I assume ...) be reproduced anymore, and therefor not a lot of value for future visitors of this question ... unless of course it repeats in the future.
    – Pierre.Vriens Mod
    Commented Mar 19, 2017 at 10:51
  • @Pierre.Vriens I don't disagree, but do we have to do this now? It's not like we're running out of room for Q&As or anything like that. As long as the post isn't misleading or damaging in some way it can stay. I might even think of it as potentially useful: if someone runs into an image uploading problem this Q&A would offer a possible cause to maybe check out and/or maybe a better place to look, no? Commented Mar 19, 2017 at 12:25
  • Fine for me. You might as well consider it as an example of a Murphy-law situation .... anything that can go wrong, will go wrong, and it shall go wrong when it shouldn't go wrong ... I mean: bad luck that this incident (or whatever) happened around the time DevOps.SE got launched ... Also: what are the actual followup-steps taken by SE to prevent it from happening in the future, sounds like a DRP-topic (if you know that TLA), no?
    – Pierre.Vriens Mod
    Commented Mar 19, 2017 at 12:43
  • Right. BTW Assaf's chat comment was golden: Look how quickly I can clear this room.. [ahem] S3 IS DOWN!!! Commented Mar 19, 2017 at 12:58
  • @Pierre.Vriens: DRP as in disaster recovery planning I presume. The accepted answer to the post linked in Robert's answer has a few notes. Commented Mar 19, 2017 at 13:06

1 Answer 1


Amazon S3 US-East-1 is down. That is the cause of many of today's issues you may see around the network and the Internet in general.

Meta SE or the thread below is probably the best place to watch for updates:

Intermittent Failed to upload image; imgur is rejecting the request.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .